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1 What you need to know before starting

HSimulator is an optimized, multithread Java simulator compatible with Java
6.0 or higher versions. The software works both as a standalone simulator
and as a Javadoc documented Java library.

1.1 Introduction

HSimulator is compiled by means of Java 6.0. As any Java software, it
is completely platform independent and it can be executed wherever it is
installed a Java 6.0 runtime environment. This software has been tested on
Windows XP, Windows 7, Windows 10, Linux and OS X.

1.1.1 Dependences of the software

In order to implement all the facilities provided by the software, a big part
of the code is based on a set of functions that are distributed by other Java
projects. The imported libraries are distributed together with HSimulator
in the folder lib which needs to be placed in the same folder of the JAR
archive of HSimulator. The imported Java libraries are:

• JFreeChart: a chart library to display professional quality charts.

• Jxl: a mature java API enabling developers to read, write, and modify
Excel spreadsheets dynamically.

• RSyntaxTextArea: a syntax highlighting, code folding text editor for
Java Swing applications.
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1.2 How to launch

As HSimulator is a portable application there is no need to install it. The
software works both in terminal and in a graphical environment. In the latter
case a graphical user interface is automatically displayed.

• To launch HSimulator on Windows and OS X Environments:

1. Double-click on the archive HSimulator.jar

2. If, for any reason, this does not work, open the command prompt,
move to the main project folder and type this command:

java −j a r HSimulator . j a r

• To launch the application on Linux Environments:

1. Open the terminal, move to the main project folder and type this
command:

java −j a r HSimulator . j a r

• To force the execution in terminal:

1. Open a command prompt, move to the main project folder and
type this command to display the help:

java −j a r HSimulator . j a r −help

• To use HSimulator as a Java library we refer to the attached Javadoc
documentation and to the example code Gemcitabine.java
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1.3 Graphical user interface (GUI)

After having launched the application in a graphical environment, a graphical
user interface will be automatically loaded (see Figure 1). The window
contains, on the left, a syntax highlighting text editor, where you can type
a new model speci�cation or open an existing one. The right side contains,
on the top, the compulsory options needed to run the simulation and on the
bottom a space area where simulation charts will be displayed.

Figure 1: The HSimulator GUI.

The interface includes also a progress bar that indicates the status of the
current simulation process and three buttons:

i Start/Resume Simulation: it starts or resumes the simulation. Enabled
only when all parameters are set.

ii Pause Simulation: it pauses a simulation process before its completion.
If pressed again, the process can be resumed.

iii Stop Simulation: stops a simulation before its completion.
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1.4 How to run your �rst simulation

The software simulates biochemical reaction networks de�ned in a txt by
means of a very simple syntax (see section 2 for details). Therefore, the �rst
thing to do is to have a model speci�cation loaded in the text editor. You can
do this by typing the model description in the editor by opening an existing
one stored as a txt �le.

In this demonstrative example, we are going to pick up an example model
by clicking on File→ Open model. From here select the �le MAPK.txt, which
is included with the software.

Once you have the model speci�cation loaded, in order to run the sim-
ulation you will only need to select a simulation algorithm (default value =
HRSSA, see Section 3) and to provide a value for the parameter simulation
length (default value = 1). All other parameters are already set by default,
hence there is no need to worry about them for a �rst trial. Now that all
the options are given, the Start button turns enabled and you can start
your �rst simulation with HSimulator. Once the process is completed, a sim-
ulation chart will appear on the right-bottom side of the GUI (see Figure
2).

When the simulator is working in a terminal, you can obatin the same
simulation of Figure 2 by the following command:

java −j a r HSimulator . j a r −a lg=r s s a −tMax=2 MAPK. txt

Simulation results will be automatically collected in an excel worksheet. If
possible, the plot of the simulation can be generated by adding the argument
-doPlot.
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Figure 2: The HSimulator GUI showing a simulation.

2 Model speci�cation

HSimulator accepts a textual description of the biochemical network to sim-
ulate, which can be also partitioned in several reaction volumes (multi-
compartmental modeling). Each model reaction is de�ned according to stan-
dard arrow based notation and must be equipped with a mass-action stochas-
tic reaction constant according to [2]. In Figure 3 we provide an example
of biochemical reaction network with 5 volumes. The same speci�cation is
available in the model �le ModelSpecification.txt.

The textual speci�cation of the model starts with the de�nition of the
reaction volumes (the �rst line is a comment, you can add comments with
the hashtag character), which are indicated using round brackets to represent
compartment inclusion (see also Figure 4). Immediately after the speci�ca-
tion of the compartment hierarchy, the units of measurement of volume and
time have to be speci�ed:

un i t s o f measurement volume=ml (cm^3) , time=min

These are global units, that is, all compartment volumes and simulation
length have to be speci�ed according to these units of measurement.
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# This i s an example o f b iochemica l r eac t i on network
System (PlasmaMembrane ( Cytosol ( Organel le , Nucleous ) ) )
un i t s o f measurement volume=ml (cm^3) , time=min

System
volume=100
abundances A=20, B=100

B + A −> B:A ra t e 100 .0
B:A −> B + A rate 100 .0
2C + B −> D + 3B rat e 100 .0
E + F −> G@Cytosol + F ra t e 100 .0

−> H rate 100 .0
D −> rate 100 .0

PlasmaMembrane
volume=0.2

Cytosol
volume=0.1

Nucleous
volume=0.05
abundances I=5, L=8

I −> L :M rat e 100 .0

Organe l l e
volume=0.05

Figure 3: An example of biochemical reaction network with 5 volumes. The
same speci�cation is available in the model �le ModelSpecification.txt.

The textual speci�cation continues with the de�nition of each single com-
partment. For each compartment we have to specify the volume size, the
abundances of available species (not declared species are assumed to have
zero abundance) and �nally the list of reactions acting in the compartment.
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Figure 4: The hierarchy of compartments speci�ed by the line of code
System(PlasmaMembrane(Cytosol(Organelle,Nucleous))).

System
volume=100
abundances A=20, B=100

B + A −> B:A ra t e 100 .0
B:A −> B + A rate 100 .0
2C + B −> D + 3B rat e 100 .0
E + F −> G@Cytosol + F ra t e 100 .0

−> H rate 100 .0
D −> rate 100 .0

Each reaction has to be equipped with a mass-action stochastic reaction con-
stant according to [2]. In the de�nition of a reaction, you can use : to de�ne
complexes, @ to indicate species location (G@Cytosol means species G in

8



compartment Cytosol) and implicit multiplication to indicate stoichiometric
coe�cients (2C means two molecules of species C).

Please note that you can check whether your model speci�cation syntax
is correct by clicking on the Check button of the GUI toolbar, or by clicking
on View→ Check Model. If an error occurs, an error dialog will be prompted
displaying the message error.

2.1 Examples of model speci�cation

To exemplify the way in which a reaction network can be textually speci�ed
in the simulator, in the following we will shortly present some biochemical
models that are distributed with the software. We refer to [3] for a complete
description of models and for simulation benchmarks.

2.1.1 Oregonator

Oregonator is a simple biochemical oscillator inspired by the phenomenon
initially discovered by Belousov and Zhabotinsky. The model is important
because it exhibits oscillating phenomena even if the system is far from the
thermodynamic equilibrium. The Oregonator is of interest for both theoret-
ical research and practical simulation.

Figure 5: Oregonator model.
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2.1.2 MAPK

The mitogen-activated protein kinase cascade (MAPK) describes a chain of
proteins that cascade a signal from the cell receptor to its nucleus and result
with a cellular response, i.e., cell proliferation, division and apoptosis. The
MAPK pathway is stimulated when ligands, e.g., growth factors, bind to the
receptor on the cell surface. The process is controlled through three main
proteins kinases: MAPKKK, MAPKK and MAPK. The propagation of the
stimulated signal is cascaded by sequential phosphorylation.

Figure 6: MAPK model.

2.1.3 Gemcitabine

Gemcitabine (2,2-di�uorodeoxycytidine, dFdC) is an anti-cancer chemother-
apy drug. It has been used to treat di�erent types of cancer including
non-small-cell lung cancer, pancreatic cancer, bladder cancer, and breast
cancer. Gemcitabine produces clinical e�ects by incorporating its triphos-
phatemetabolite (dFdCTP) into DNA leading to the inhibition and blocking
of DNA synthesis. The gemcitabine model has been developed to under-
stand the mechanisms of resistance to gemcitabine e�cacy. The model de-
tails mechanisms for the race between gemcitabine and natural nucleoside
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triphosphate dCTP for DNA incorporation. It also includes the mechanisms
of resistance by considering the role of ribonucleotide reductase (RR), de-
oxycytidine kinase (dCK) and human equilibrative nucleoside transporter1
(hENT1).

Figure 7: Gemcitabine model.
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3 Simulation

HSimulator provides an implementation of �ve state of the art simulation
strategies covering exact stochastic simulation (DM and RSSA), determinis-
tic simulation (Forward Euler and the Runge-Kutta-Fehlberg RK45 adaptive
algorithm) and hybrid simulation (HRSSA). When deterministic or hybrid
simulation is selected, the simulator automatically translates the reaction
network into a set of mass-action ODEs.

The simulator GUI o�ers on the right side a panel devoted to the simu-
lation process. From here you can decide the simulation algorithm and the
simulation parameters (when the simulator is launched in terminal, we refer
to the help printed with the argument -help).

Figure 8: Panel dedicated to the simulation process.

The mandatory parameter simulation length indicates the temporal
duration of the simulation. Figure 9 provides the dynamics of the Gemc-
itabine model with with simulation length of 24 hours. The parameter time
sampling indicates the discretization time interval used to store the dynam-
ics of the model. For instance, with a time sampling of 0.01, HSimulator will
store the model dynamics at time steps of 0.01 units of time (instants 0, 0.01,
0.02, . . . ).

In Figures 10 and 11 it is possible to evaluate how plot changes in relation
to the time sampling: larger values decrease the number of saved points and
the plot will become less accurate. Please note that you can also decide
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Figure 9: Gemcitabine dynamics with simulation length of 24 hours.

to view the plot in logarithmic scale by means of the View menu. It is
important to stress that the time sampling does not a�ect the computation
of the dynamics, but only the way in which the simulator stores computed
time series.

3.1 Algorithms

The software allows to simulate a model according to di�erent simulation
algorithms. When you select an algorithm in the simulator GUI, you can
have access to its settings by clicking the Advanced Options button (when
the simulator is launched in terminal, we refer to the help printed with the
argument -help).
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Figure 10: Gemcitabine dynamics with simulation length = 1 hour and
time sampling = 0.25.

Figure 11: Gemcitabine dynamics with simulation length = 1 hour and
time sampling = 0.01.

3.1.1 Direct Method (DM)

This is an implementation of the Gillespie Direct Method [2]. You do not
need to specify any setting for running the simulation, however, the software
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allows to compute more than one simulation in parallel for computing an
averaged dynamics. The number of simulations is indicated by the parameter
number of simulations to compute.

Figure 12: Advanced Options for Gillespie's DM
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3.1.2 Rejection-based Stochastic Simulation Algorithm (RSSA)

RSSA [5, 6, 4, 7] is an exact stochastic algorithm equivalent to the Direct
Method, which has an e�cient way of computing reaction propensities. RSSA
is currently the fastest algorithm available in literature for exact stochastic
simulation. It has three parameters that can be set:

Figure 13: Advanced Options for RSSA.

Number of simulation to compute: number of simulations to compute
in parallel to obtain the averaged dynamics of the system.

Delta for calculating the state fluctuation interval: this is the
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value used to compute the �uctuation interval of the current system
state X. Such an interval is computed by:

[X − δX,X + δX].

The size of the �uctuation interval a�ects the runtime of RSSA, but
not the accuracy of the computation (RSSA is an exact stochastic al-
gorithm). We refer to [5] for any insight into the matter.

Minimum size of the state fluctuation interval: this parameter will
set the minimum admitted size of the �uctuation interval. If during the
simulation that interval will be tighter that the size set by this param-
eter, the algorithm will enlarge the interval to ful�ll the requirement.
This parameter does not a�ect the accuracy of the simulation, but, like
δ parameter, changes the runtime.

3.1.3 Euler Algorithm

This is a simple implementation of the forward Euler method for determinis-
tic simulation [1]. This numerical algorithm is a �rst order method provided
for didactic purposes. We recommend to use the RK45 algorithm for having
more accurate simulations (see next section). It has one parameter that can
be set:

Discretization step: this parameter specify the discretization step-size
of the algorithm.

3.1.4 Runge-Kutta-Fehlberg algorithm (RK45)

RK45 is an adaptive numerical method that provides e�cient deterministic
simulation [1]. It has two parameters that can be set:

Initial discretization step: this parameter specify the discretization
step-size adopted by the algorithm at the beginning of the simulation.
This value will be then automatically adapted during the simulation to
preserve the accuracy of the computation.

Maximum error admitted: threshold for the maximum truncation error
admitted at each simulation step.
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Figure 14: Advanced options for Euler Algorithm
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Figure 15: Advanced Options for RK45 Algorithm.
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3.1.5 Hybrid Rejection-based Stochastic Simulation Algorithm (HRSSA)

HRSSA [3] is a new e�cient hybrid stochastic/deterministic simulation al-
gorithm for spatially homogeneous biochemical reaction networks. HRSSA
allows fast simulation of large models by ensuring at same time the exactness
of the simulation of a subset of the reaction network modeling slow reactions.
This algorithm is built on top of RSSA and therefore some of its parameters
are inherited from it:

Number of simulation to compute: number of simulations to compute
in parallel to obtain the averaged dynamics of the system.

Delta for calculating the state fluctuation interval: this is the
value used to compute the �uctuation interval of the current system
state X. Such an interval is computed by:

[X − δX,X + δX].

The size of the �uctuation interval a�ects the algorithm runtime, we
refer to [3] for any insight into the matter.

Minimum size of the state fluctuation interval: this parameter will
set the minimum admitted size of the �uctuation interval. If during the
simulation that interval will be tighter that the size set by this param-
eter, the algorithm will enlarge the interval to ful�ll the requirement.

Discretization step for simulating fast reactions: this parameter
specify the discretization step-size used for the deterministic simulation
of fast reactions.

Minimum molecule number of fast reactions: the minimum amount of
molecules that has to be available for fast reactions. This value is
usually greater than 100.

Minimum number of reaction firing of fast reactions: the minimum
number of times that a fast reaction has to be applied, in average,
within the time range of size indicated by the parameter discretization
step for simulating fast reactions. This value usually ranges
between 5 and 10.
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Figure 16: Advanced options for HRSSA

3.2 Evaluation of simulation results

Once a simulation process is completed, the simulator will automatically cre-
ate an excel worksheet storing simulated time series when the simulation is
executed in terminal. When the GUI is used, instead, a plot will automat-

21



ically appear in the bottom right part of the window. Moreover, there are
some addtional actions you can do to evaluate simulation results:

Save Simulation Results: by clicking on File→ Save Simulation Results...

you can save the time series of the simulation as a Microsoft Excel .xls
�le or as a tab-separated �le (.txt �le). Note that if the time series is
very long you will only be able to save it as .txt �le.

Logarithmic scale plot: the software allows to plot time series in logarithmic
scale. This action can be done by clicking on View → Logarithmic

Scale Plot.

Print Model Simulation Plot: by clicking on File→ Print Model Simulation

Plot, you can print the simulation plot. The same action can be done
by right-clicking on the chart and selecting Print...

Show plot in a separate window: in order to analyze better the chart, the
software allows to create a new one in a separate window. This action
can be done by double-clicking on the plot, or by selecting View →
Show Plot.
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